• Be part of the TeaParty!
    Click here for more information

TeaSpeak

  • @ Broenor:
    hello all. my friend install teaspeak and why no can join. server version is too old for command
    +1
    Unlike