• Be part of the TeaParty!
    Click here for more information

Pending Closing connection

REDOSS

Well-known member
[2019-03-16 15:19:37] [[1m[7m[0;31mCRITICAL] [1m[7m[0;31m 5 | Failed to write datagram packet for client IP_1:10509 (errno: 22 message: Invalid argument). Closing connection[0m
[2019-03-16 15:19:37] [DEBUG] 5 | [IP_1:10509/redoss | 2] Closing voice client connection. (Flush: false)
[2019-03-16 15:19:37] [INFO] 5 | Voice client 2/rZxCzsRdkwgKx3/SdoQES9hGm3M= (redoss) from IP_1:10509 left.
[2019-03-16 15:19:37] [DEBUG] 5 | Deleting VoiceClient instance at 0x7f2fc986ac10
[2019-03-16 15:19:37] [[1m[7m[0;31mCRITICAL] [1m[7m[0;31m 5 | Failed to write datagram packet for client IP_2:59249 (errno: 22 message: Invalid argument). Closing connection[0m
[2019-03-16 15:19:37] [DEBUG] 5 | [IP_2:59249/я не пряня | 3] Closing voice client connection. (Flush: false)
[2019-03-16 15:19:37] [INFO] 5 | Voice client 1680/EPcXdAHFGt0Uw92ls3NtHsl0wHA= (я не пряня) from IP_2:59249 left.
[2019-03-16 15:19:37] [[1m[7m[0;31mCRITICAL] [1m[7m[0;31m 5 | Failed to write datagram packet for client IP_3:2264 (errno: 22 message: Invalid argument). Closing connection[0m
[2019-03-16 15:19:37] [DEBUG] 5 | [IP_3:2264/Кислый | 5] Closing voice client connection. (Flush: false)
[2019-03-16 15:19:37] [INFO] 5 | Voice client 11247/JKWaW9lUPM6QJhHUhQuikT7zFiE= (Кислый) from IP_3:2264 left.
[2019-03-16 15:19:37] [DEBUG] 5 | Deleting VoiceClient instance at 0x7f2fdec3b010
[2019-03-16 15:19:37] [DEBUG] 5 | Deleting VoiceClient instance at 0x7f2fc986a010
I know that the problem is already known and reproduced very rarely, but still create a topic with a discussion :) all three users have restored the connection to the server after 30 seconds. Server version 1.3.10 optimized build. The problem was also reproduced in early builds. Users do not use IPv6. Closing a connection is random and not for a single client.
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
I know that the problem is already known and reproduced very rarely, but still create a topic with a discussion :) all three users have restored the connection to the server after 30 seconds. Server version 1.3.10 optimized build. The problem was also reproduced in early builds. Users do not use IPv6. Closing a connection is random and not for a single client.
Are you binding on IPv6 as well?
If so there is already a git issue :)
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Yeah no thats not the problem. The issue is that the server binds on v6 as well and the tries to send on v6 insteadof v4, will be fixed soome :)
 

REDOSS

Well-known member
Yes, but does it binds to v6?
I was sitting on the server, listening to the bot and one day I was connection lost. Thought it was the Internet, but no... Got into logs and saw this error and noticed that not only me, and two more people with the similar reason.