• Hey Guest, we're evolving the future of TeaSpeak.
    You're invited to join the discussion here!

Information Instructions to install TeaSpeak Server in Linux

moskito

New member
I still have the problem. Please write a solution here in this forum. It is of no use to users if the problem is solved privately.
 

Kometex

New member
Hello,

I get the following problem:


teaspeak@plorux:~$ ./teastart_autorestart.sh start
Starting the TeaSpeak server screen (Uid: e71bNEHMBA4vNatpHbCmo0BlouMCyknu)
TeaSpeak server could not start


and


teaspeak@plorux:~$ ./teastart.sh start
Starting the TeaSpeak server..
Could not start TeaSpeak server.
Last log entries:
[2020-10-12 09:16:20] [DEBUG] Log successfully started!
[2020-10-12 09:16:20] [INFO ] GEN | Starting TeaSpeak-Server v1.4.22-beta [Build: 1601813390]
[2020-10-12 09:16:20] [INFO ] GEN | Starting music providers
[2020-10-12 09:16:20] [DEBUG] [Music] Provider load order:
[2020-10-12 09:16:20] [DEBUG] [Music] [0] providers/000ProviderFFMpeg.so
[2020-10-12 09:16:20] [DEBUG] [Music] [1] providers/001ProviderYT.so
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Using config file located at providers/config_ffmpeg.ini
[2020-10-12 09:16:20] [INFO ] [Music] [FFMPEG] Config successfully loaded
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Executing command "/home/teaspeak/providers/bin/ffmpeg -version"
[2020-10-12 09:16:20] [INFO ] [Music] [FFMPEG] Resolved ffmpeg with version "ffmpeg version 4.0.1-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2018 the FFmpeg developers"
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Executing command "/home/teaspeak/providers/bin/ffmpeg -protocols"
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Executing command "/home/teaspeak/providers/bin/ffmpeg -formats"
[2020-10-12 09:16:20] [INFO ] [Music] Loaded successfully provider FFMpeg
[2020-10-12 09:16:20] [INFO ] [Music] Loaded successfully provider YouTube
[2020-10-12 09:16:20] [INFO ] [Music] [YT-DL] Compiling patterns





I did everything as stated in the instructions.
 

otalportista

Fanatic member
Hello,

I get the following problem:


teaspeak@plorux:~$ ./teastart_autorestart.sh start
Starting the TeaSpeak server screen (Uid: e71bNEHMBA4vNatpHbCmo0BlouMCyknu)
TeaSpeak server could not start


and


teaspeak@plorux:~$ ./teastart.sh start
Starting the TeaSpeak server..
Could not start TeaSpeak server.
Last log entries:
[2020-10-12 09:16:20] [DEBUG] Log successfully started!
[2020-10-12 09:16:20] [INFO ] GEN | Starting TeaSpeak-Server v1.4.22-beta [Build: 1601813390]
[2020-10-12 09:16:20] [INFO ] GEN | Starting music providers
[2020-10-12 09:16:20] [DEBUG] [Music] Provider load order:
[2020-10-12 09:16:20] [DEBUG] [Music] [0] providers/000ProviderFFMpeg.so
[2020-10-12 09:16:20] [DEBUG] [Music] [1] providers/001ProviderYT.so
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Using config file located at providers/config_ffmpeg.ini
[2020-10-12 09:16:20] [INFO ] [Music] [FFMPEG] Config successfully loaded
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Executing command "/home/teaspeak/providers/bin/ffmpeg -version"
[2020-10-12 09:16:20] [INFO ] [Music] [FFMPEG] Resolved ffmpeg with version "ffmpeg version 4.0.1-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2018 the FFmpeg developers"
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Executing command "/home/teaspeak/providers/bin/ffmpeg -protocols"
[2020-10-12 09:16:20] [DEBUG] [Music] [FFMPEG] Executing command "/home/teaspeak/providers/bin/ffmpeg -formats"
[2020-10-12 09:16:20] [INFO ] [Music] Loaded successfully provider FFMpeg
[2020-10-12 09:16:20] [INFO ] [Music] Loaded successfully provider YouTube
[2020-10-12 09:16:20] [INFO ] [Music] [YT-DL] Compiling patterns





I did everything as stated in the instructions.
You don't have more in logs?
 

otalportista

Fanatic member
Try that:
Code:
wget https://repo.teaspeak.de/server/linux/amd64_optimized/TeaSpeak-$(curl -k https://repo.teaspeak.de/server/linux/amd64_optimized/latest).tar.gz