• Be part of the TeaParty!
    Click here for more information

Memory Leak / Fragmention bug

Koyilin

Member
Hello, i tried different versions of teaspeak on different os the problem was always the same, the memory witch teaspeak server uses every single time getting larger and larger it starts about 20mb and grows until the vps ram is full and then crash, i installed jemalloc i tried ubuntu x64 , centOS 7 and i tried different versions like:
1.2.15 beta 11
1.2.13 beta 4
1.2.14 (i dont remember witch beta version i tried)
and maybe it helped a bit but nothing solved this problem and another thing: if more peaple are connected the server the memory grows faster , with less peaple connected the memory grows slower but the result is the same it grows until the crash or restart.
sorry for my bad english.
 

mkll11one

TeaFanatic
Premium User
Dude.. Try use 1.2.15-beta11 i dont have any problems on it. ;)

But hey.. how many memory do you have? - Post a meminfo (You can do it from teaspeak_minimal.sh) :)
 

andrex1337

Active member
basicly 5-10 when i invite my wow guild to raid there that means 30+5-10 ppl so sometimes 30+ ppl
Hm.. I doesnt have any problems with my server like that. Please tell us some more informations about your VPS. How much RAM you have?
 

Koyilin

Member
Dude.. Try use 1.2.15-beta11 i dont have any problems on it. ;)

But hey.. how many memory do you have? - Post a meminfo (You can do it from teaspeak_minimal.sh) :)
Im using it now and nothing new, :/ i have 512mb memory thats not that much but its a Tea*Speak server and i didnt install nothing else.It worked fine in the past just the new teaspeak generate this problem.
Hm.. I doesnt have any problems with my server like that. Please tell us some more informations about your VPS. How much RAM you have?
512mb
 

mkll11one

TeaFanatic
Premium User
Im using it now and nothing new, :/ i have 512mb memory thats not that much but its a Tea*Speak server and i didnt install nothing else.It worked fine in the past just the new teaspeak generate this problem.

512mb
Hmm.. i have 32 GB on a VPS. and i dont have any issues. ;)
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Well i wont pay for something witch i wont use, in a normal case 512mb for 30 users should be enough
I agree 512mb for only 30 users are definitely enough (except when you have thousands of channel xD)

Can you post your jemalloc statistics in here?

Type meminfo within the Teaspeak terminal
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Hey,
I'll analyze them later but a quick overview showed me the expected. The most of the allocated memory isn't used and just floating around :)
 

Koyilin

Member
Hey,
I'll analyze them later but a quick overview showed me the expected. The most of the allocated memory isn't used and just floating around :)
And another (maybe helpfull maybe not) thing at the start when we come to raid to the teaspeak the connected users was between 28-35 and when we connected this was the ram usage :
1536438127330.png

At the end the raid(4hours later) the ram usage was:
1536438209928.png
And then when everyone disconnected the ram usage become lower but still not normal(the remaring connected users was about 5-7)
1536438268177.png
 

Koyilin

Member
Hey,
I'll analyze them later but a quick overview showed me the expected. The most of the allocated memory isn't used and just floating around :)
And i have a question, witch os are u using to test / debug / fix the teaspeak server?
so witch is the most stable os for teaspeak?