• Be part of the TeaParty!
    Click here for more information

Musicbot

yamano

Fanatic member
Premium User
SOLVED just by installing manually FFMpeg and Yt-dl and restarting Teaspeak server ;)
 

zehir

Active member
Got an error while trying to load next song: Failed to parse song info: failed to load info provider


I get an error. FFMpeg , youtube loaded
 

Kevinos

TeaSpeak Team
Staff member
TeaTeam
Premium User
Got an error while trying to load next song: Failed to parse song info: failed to load info provider


I get an error. FFMpeg , youtube loaded
Try run the file install_music.sh
 

zehir

Active member
Try run the file install_music.sh

Root@Tea*Speak:/home/Teaspeak# ./install_music.sh install
Testing/Installing FFMPEG
Local installed FFMPEG version (4.1.1) is okey. No need to install FFMPEG.
Testing/Installing youtube-dl
Local YouTube-DL version (2019.06.08) is okey. No need to install it


problem persists
 

REDOSS

Well-known member
Root@Tea*Speak:/home/Teaspeak# ./install_music.sh install
Testing/Installing FFMPEG
Local installed FFMPEG version (4.1.1) is okey. No need to install FFMPEG.
Testing/Installing youtube-dl
Local YouTube-DL version (2019.06.08) is okey. No need to install it


problem persists
./install_music.sh install -y
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
apt-get remove ffmpeg
apt-get purge ffmpeg
apt-get autoremove
./install_music.sh install -y

After these commands, try rebooting your instance TeaSpeakServer and trying again.
Important thing there is that this script installs a individual library only used for the TeaSpeak server! So if you want to update YT-DL or FFMPEG you've to use this script again, or remove the .ini files within the providers/ directory.
 

REDOSS

Well-known member
Important thing there is that this script installs a individual library only used for the TeaSpeak server! So if you want to update YT-DL or FFMPEG you've to use this script again, or remove the .ini files within the providers/ directory.
I suspected he had an outdated local version installed. So I gave these commands to remove the local and install the version from the script. I always update libraries as you described. ;)