• Be part of the TeaParty!
    Click here for more information

Simple Server Hosting Script

Kalle801

Active member
Premium User
Welche php version ist das?
Wenn ich den Create button klicke, bekomme ich nen fehler: Website nicht erreichbar. HTTP ERROR 500
 

Kalle801

Active member
Premium User
Code:
[Thu May 02 13:31:24.102965 2019] [:error] [pid 12810] [client 162.158.111.34:14296] PHP Fatal error:  Uncaught Error: Call to undefined function utf8_encode() in /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Helper/String.php:472\nStack trace:\n#0 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Adapter/ServerQuery.php(204): TeamSpeak3_Helper_String->toUtf8()\n#1 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Node/Abstract.php(82): TeamSpeak3_Adapter_ServerQuery->prepare('login', Array)\n#2 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Node/Abstract.php(94): TeamSpeak3_Node_Abstract->prepare('login', Array)\n#3 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Node/Host.php(824): TeamSpeak3_Node_Abstract->execute('login', Array)\n#4 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/TeamSpeak3.php(346): TeamSpeak3_Node_Host->login(Object(TeamSpeak3_Helper_String), Object(TeamSpeak3_Helper_String))\n#5 /var/www/html/teamtalk.pw/index.php(7): TeamSpeak3::factory(Object(TeamSpeak3_Helper_Uri))\n#6 {main}\n  thrown in /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Helper/String.php on line 472, referer: https://teamtalk.pw/
public function toUtf8()
{
if(!$this->isUtf8())
{
$this->string = utf8_encode($this->string);
}

return $this;
}
 

Kalle801

Active member
Premium User
Würde ich ja machen, aber dieses folder gibt es nicht: open the config.php in webinterface folder edit lines 36-38

Edit: PS: Mit den locales hattest du recht. Musste die erst installieren.
 

BIOS

Well-known member
ja das webinterface ist das was hier nen extra threat hat, gab früher maln komplett package ;)
 

Kalle801

Active member
Premium User
oh. Magst du mir nen link dahin geben?

BTW: Diesen eror bekomme ich jetzt. Das nicht vorhandene Interface ist also nicht schud, denke ich.
Code:
[php7:error] [pid 19645] [client 77.23.146.13:54411] PHP Fatal error:  Uncaught TeamSpeak3_Adapter_Exception: invalid reply from the server (TeamTalk) in /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Adapter/ServerQuery.php:77\nStack trace:\n#0 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Adapter/Abstract.php(57): TeamSpeak3_Adapter_ServerQuery->syn()\n#1 /var/www/html/teamtalk.pw/libraries/TeamSpeak3/TeamSpeak3.php(338): TeamSpeak3_Adapter_Abstract->__construct(Array)\n#2 /var/www/html/teamtalk.pw/index.php(7): TeamSpeak3::factory(Object(TeamSpeak3_Helper_Uri))\n#3 {main}\n  thrown in /var/www/html/teamtalk.pw/libraries/TeamSpeak3/Adapter/ServerQuery.php on line 77, referer: https://teamtalk.pw/
 

BIOS

Well-known member
mir ist übrigends aufgefallen das du hattp sowie https aktiv hast das solltest du mit einem http zu https rewrite anpassen das automatisch die https augerufen wird