TeaSpeak Installer

Sporesirius

Well-known member
This is a TeaSpeak installation script that installs TeaSpeak, all necessary packages and creates a user.
*The installer requires sudo or root privileges.

NOTE: Currently older distribution versions do not work e.g. Ubuntu 12, CentOS 6...

Latest version: https://github.com/Sporesirius/TeaSpeak-Installer/releases/latest
Github Repo: https://github.com/Sporesirius/TeaSpeak-Installer

or

Code:
wget https://github.com/Sporesirius/TeaSpeak-Installer/raw/master/teaspeak_install.sh
Code:
chmod 774 teaspeak_install.sh
Code:
./teaspeak_install.sh

Currently supported distributions:

Tested:
  • Debian
  • Ubuntu
  • openSUSE
  • CentOS (requires an additional repository for ffmpeg)
  • Arch
  • Fedora (requires an additional repository for ffmpeg)
Not tested, but should work:
  • RedHat (requires an additional repository for ffmpeg)
  • Mint
Not working:
  • Ubuntu 12
  • CentOS 6
 
Last edited:

Sporesirius

Well-known member
There are tools (Webinterfaces, etc.) that require SSH access, but you are right I will also add the non-login option.

EDIT: Added Nologin option.
 
Last edited:

Bluscream

Well-known member
thanks, btw when i try your script with this tutorial i get an endless loop:

Code:
We're missing a required package!
Please install 'libav-tools' (apt install libav-tools -y)
Should we do this for you? [Y/n]: y
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  ffmpeg

E: Package 'libav-tools' has no installation candidate

We're missing a required package!
Please install 'libav-tools' (apt install libav-tools -y)
Should we do this for you? [Y/n]:
 

Sporesirius

Well-known member
thanks, btw when i try your script with this tutorial i get an endless loop:

Code:
We're missing a required package!
Please install 'libav-tools' (apt install libav-tools -y)
Should we do this for you? [Y/n]: y
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  ffmpeg

E: Package 'libav-tools' has no installation candidate

We're missing a required package!
Please install 'libav-tools' (apt install libav-tools -y)
Should we do this for you? [Y/n]:
But this is not from my script, did you start teastart_minimal.sh?


Do you use Ubuntu Bionic Beaver (18.04)?

Are there no libav-tools in the Ubuntu Bionic Repository?
 

d0nar

New member
thanks, btw when i try your script with this tutorial i get an endless loop:

Code:
We're missing a required package!
Please install 'libav-tools' (apt install libav-tools -y)
Should we do this for you? [Y/n]: y
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  ffmpeg

E: Package 'libav-tools' has no installation candidate

We're missing a required package!
Please install 'libav-tools' (apt install libav-tools -y)
Should we do this for you? [Y/n]:
i am wondering why you get ubuntu bionic repositories o_O

1532509106247.png

could you try to
sudo apt-get update
and then
apt-cache search libav-tools
and if it finds it,
sudo apt-get install libav-tools

then please run the installer again
but with
sudo ./teaspeak_install.sh
 

Sporesirius

Well-known member
Ubuntu Bionic repository do not have libav-tools :(

Code:
root@ubuntu-vm03:~# apt-get install libav-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libav-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  ffmpeg

E: Package »libav-tools« has no installation candidate
 
Last edited:

d0nar

New member
Sry for the delay, had to attend to an birthday and yeah, it went a bit out of control :ROFLMAO:

I am still confused how you got Ubuntu bionic 😅
As when I follow my tutorial step by step I end with
Ubuntu 16.04.05 LTS
So it's "xenial"

Did you do any steps that I didn't mention in my tutorial?

hm and when i lookup the libav tools on launchpad i see that it got removed and in the description is this:

This is a transitional package that provides the following links:
* avconv -> ffmpeg
* avplay -> ffplay
* avprobe -> ffprobe
This package can be removed, when nothing uses the av* program names anymore.


so i think it might work to just update the script and maybe teaspeak, to use ffmpeg directly


EDIT:

found out MS does publish 2 ubuntus or may transited to bionic, will now manually force upgrade on my machine and will look for an fix

EDIT:

could it be that teaspeak server does not need libav-tools?
 
Last edited:

d0nar

New member
Solution, replace in teastart_minimal.sh
'apt;apt list --installed % | grep %;apt update;apt install % -y;libav-tools'
with
'apt;apt list --installed % | grep %;apt update;apt install % -y;ffmpeg'

and it runs without problems :)

@Sporesirius i think you can alter your script to use ffmpeg direct instead of using libav-tools :)
 

d0nar

New member
@Sporesirius but do we need the webclient on the server?
oh and also, as libav-tools is just an binding package that makes the libav names usable with ffmpeg backend, it should only be
search and replace to transit to native ffmpeg and ditch libav-tools

@WolverinDEV what do you think?
 
Last edited:

Sporesirius

Well-known member
Maybe i misunderstood but i think that libav-tools is needed that the TeaSpeak Server can connect to the webclient but as I said, Wolverine can say more about it.
 

d0nar

New member
@Sporesirius but in ubuntu
libav-tools
is just hm an symbolic link to ffmpeg as far as i found out, so it is an obsolete piece of software and is replaced with ffmpeg now in ubuntu bionic
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Hey,
Well libavtools seems to be a general issue.
In general it's needed for Webrtc, else if you enabled Web the server would crash. Because the last few builds was without it caused to my vacation it want required :)

As a side effect:
It also contains ffmpeg so you don't have to install it :)

As a view to the future:
Webrtc will be included as soon im at home, so this package is required anymore.
I already found a alternative to the big webrtc project, which I may use later to remove the Webrtc sh*t and make the binary smaller :)
 

heartles39

Fanatic member
./teastart_minimal.sh
./teastart_minimal.sh: line 49: packageManagersList: bad array subscript
./teastart_minimal.sh: line 49: packageManagersList: bad array subscript
./teastart_minimal.sh: line 49: packageManagersList: bad array subscript
./TeaSpeakServer: error while loading shared libraries: libnice.so.10: cannot open shared object file: No such file or directory

help me :(
 

mkll11one

TeaFanatic
Premium User
./teastart_minimal.sh
./teastart_minimal.sh: line 49: packageManagersList: bad array subscript
./teastart_minimal.sh: line 49: packageManagersList: bad array subscript
./teastart_minimal.sh: line 49: packageManagersList: bad array subscript
./TeaSpeakServer: error while loading shared libraries: libnice.so.10: cannot open shared object file: No such file or directory

help me :(
Which OS are you using? Debian / Ubuntu? - do apt-get install libnice10