Keine Verbindung (Verbindung geschlossen)

FloDer

Member
Hallo zusammen,

ich mache dann doch lieber mal ein Beitrag offen.

Ich habe folgendes Problem, wenn ich mich via Teaspeak Client verbinde bekomme ich nur eine Meldung:

Verbindung geschlossen
Die Verbindung wurde vom Remote-Host geschlossen

Wenn ich nun die Verbindung via WebClient herstelle klappt das nach der SSL Meldung ohne Probleme.

Vielen Dank vorab. :)

Viele Grüße
FloDer
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Moin,
hast du vielleicht eine Firewall, welche UDP blockiert?
Ansonsten hast du schon geprüft, ob der Server überhaupt auf UDP horcht? (netstat -lnp | grep "TeaSpeak")

Mit freundlichen Grüßen

PS: Ich glaube ich weiß jetzt, was mit "der Client" gemeint war.
Nein, es gibt keine Deaktivierung/Aktivierung Einstellungsmöglichkeit für den TeaClient.
Standardmäßig sollte eine Verbindung möglich sein.
 

FloDer

Member
Moin,

über Debian hab ich keine ufw drin, also der Port ist offen.

Eine Verbindung per TeaWebClient geht ja und wenn der Port zu wäre müsste das ja auch nicht gehen.

Den TeaClient hab ich auch schon per Firewall freigegeben.

Per Query komme ich z.B. auf den Server drauf.

Gruß
Florian
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Hey,
der WebClient funktioniert über TCP, der native Client über UDP, dies sind zwei verschiedene Sachen.
Was gibt denn der "netstat" command zurück?
 

FloDer

Member
Hey,

ah okey verstehe, dann anbei mein NetStat:

Bash:
tcp        0      0 0.0.0.0:30303           0.0.0.0:*               LISTEN      1000       35572922   28622/./TeaSpeakSer
tcp        0      0 0.0.0.0:9987            0.0.0.0:*               LISTEN      1000       35572962   28622/./TeaSpeakSer
tcp        0      0 0.0.0.0:10101           0.0.0.0:*               LISTEN      1000       35572939   28622/./TeaSpeakSer
tcp6       0      0 :::30303                :::*                    LISTEN      1000       35572923   28622/./TeaSpeakSer
tcp6       0      0 :::9987                 :::*                    LISTEN      1000       35572963   28622/./TeaSpeakSer
tcp6       0      0 :::10101                :::*                    LISTEN      1000       35572940   28622/./TeaSpeakSer
udp        0      0 0.0.0.0:9987            0.0.0.0:*                           1000       35572951   28622/./TeaSpeakSer
udp6       0      0 :::9987                 :::*                                1000       35572952   28622/./TeaSpeakSer
Komisch ist halt auch, dass der Query über TCP auch geht.

Gruß
Florian

---- Automatically Merged Double Post ----

Hey,

ich habe mir das gerade nochmal angeschaut und zum testen auf einem anderen Server mit IPv4 und IPv6 erstellt, es scheint das IPv6 Protokoll zu sein, über IPv4 komme ich somit auf den Testserver drauf mit IPv6 nicht.

Ich benötige aber IPv6 im Client, da der Server nur eine IPv6-Adresse hat.

Vielen Dank und Gruß
Florian
 
Last edited:

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Hey,
das mit IPv6 ist interessant, beziehungsweise solltest du mal vorher erwähnt haben.
Grundsätzlich sollte der native Client eigentlich IPv6 unterstützen, aber leider muss ich zugeben, dass ich dies nur ein paarmal bei der tatsächlichen Implementierung getestet hatte.

Ich habe gerade noch mal geschaut und es scheint so, als würde es inzwischen nicht mehr gehen.

Ich plane mal ein Client - Update für Montag/Dienstag.
Heute will ich noch die neue WebSite fertig machen ;)

Grüße
WolverinDEV