• Hey Guest, we're evolving the future of TeaSpeak.
    You're invited to join the discussion here!

1.5.0 - Crash collection

fenomen336

Active member
Premium User
@WolverinDEV I want to switch to version 1.4.22 using 1-5-12

---- Automatically Merged Double Post ----

I want to trade without losing data. I have too many customers.
 
Last edited:

REDOSS

TeaSpeak Team
Staff member
TeaTeam
@WolverinDEV I want to switch to version 1.4.22 using 1-5-12

---- Automatically Merged Double Post ----

I want to trade without losing data. I have too many customers.
In theory, you can roll back to a previous version. The database should be compatible, but for the future, I recommend making regular backups of your server so that you can go back to previous versions at any time.

Stop your instance and extract the files of version 1.4.22 with the replacement to the directory of your server.

P.S:. Before extracting, I would recommend making a backup copy of your server, as well as clearing the "libs" folder in the server directory itself, since in version 1.5.0 some libraries were changed, merged (I recommend doing this to avoid possible conflict).
 

Vafin

TeaFanatic
I have a suspicion that the TS3 client may be the cause of the failures, since there are no problems on the test server where only TeaClient is used. And on the server where only the TS3 client is mainly used, server crashes are observed. (Server version 1.5.0 beta 12)
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
I have a suspicion that the TS3 client may be the cause of the failures, since there are no problems on the test server where only TeaClient is used. And on the server where only the TS3 client is mainly used, server crashes are observed. (Server version 1.5.0 beta 12)
Well that can't be the difference since all use the exact same protocol.
May the actions they perform differ though.
 

Cloudshi

Active member
ich teste es mal ich habe jetzt jetzt geupdatet mal schauen ob er wieder abstürzt oder nicht wenn mehr als 25 leute drauf sind weil dann hat er sich immer auf gehangen ich nutze den teaclient aber leider nicht alle der Nutzer deswegen habe ich sehr lange Version: 1.4.14 version laufen lassen die lief immer ohne Probleme aber dort fehlen ja die ganzen neuen Sachen von teaspeak und der neue client fuktioniert da leider auch nicht bzw er stürzt ja ab wegen dem neuen teaspeak Befehlssatz muss da auch eine alter version vom webclient zurückgreifen
 

fenomen336

Active member
Premium User
Man, could the error be caused by the Teaspeak web client?

---- Automatically Merged Double Post ----

I just connected via the web browser and the server crashed
 
Last edited:

WolverinDEV

TeaSpeak Team
Staff member
Administrator
1.5.1 beta 2 is out and contains a crash fix, but I don't expect it to be the one we're all searching for.
 

Vafin

TeaFanatic
1.5.1 beta 2 is out and contains a crash fix, but I don't expect it to be the one we're all searching for.
Yes, you were right

---- Automatically Merged Double Post ----

Perhaps the server crash depends on the online, because the test server (online up to 20 users) has been running for 4 days without failures, while the production server crashes every day.
 
Last edited: