• Hey Guest, we're evolving the future of TeaSpeak.
    You're invited to join the discussion here!

Pending CentOS 7 and 1.4.8 - incompatible


Fanatic member
Version 1.4.8 needs glibc_2.18 and CentOS dont have that library version. It has until glibc_2.17.

./TeaSpeakServer: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./TeaSpeakServer)

---- Automatically Merged Double Post ----

If I build from scratch a LibC Version bigger than 2.17 it gives me segmentation fault.


Using this script to build LibC (tested with 2.18 and 2.22):
mkdir ~/glibc_install22; cd ~/glibc_install22
wget http://ftp.gnu.org/gnu/glibc/glibc-2.22.tar.gz
tar zxvf glibc-2.22.tar.gz
cd glibc-2.22
mkdir build
cd build
../configure --prefix=/opt/glibc-2.22
make -j4
make install
The putting in teastart_minimal.sh this one
export LD_LIBRARY_PATH="/opt/glibc-2.22/lib;./libs/"
Last edited:


Fanatic member
glibc_2.18 needs kernel 3.10+

use ubuntu
Lol, I know it. But you can't just suggest changing the whole OS just for incompatibility with a library version.

Working on it :)
Thanks, really trying to use again TeaSpeak to check out the performance updates. It may take a while to get 2k people on it since I've sold tons of Tea*Speak (5k-8k people constantly with very low cpu and ram usage).


TeaSpeak Team
Staff member
Yeahr I'll wait for the results.
Well I actiually planned a release for this evening, but since this issue it will be prop tomorrow because the build container makes some issues.

---- Automatically Merged Double Post ----

Should be fixed :)
Last edited: