• Hey Guest, we're evolving the future of TeaSpeak.
    You're invited to join the discussion here!

Completed Error Glibc 2.24 REQUIRED

EduardoKST

Well-known member
./TeaSpeakServer: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.24' not found (required by ./TeaSpeakServer)

I have this error for 1.2.27 beta 3, for 1.2.27 beta and above its working perfectly.
How i can update from 2.23 [my current] to 2.24.
Please an tutorial.

Thanks Guys
 
Last edited:

EduardoKST

Well-known member
Say: is already up to date ! [2.23]
I need 2.24 and my Ubuntu say its already updated. [Ubuntu 16.04]
 

ZeroCz

Well-known member
Try this
Code:
sudo wget http://security.ubuntu.com/ubuntu/pool/main/g/glibc/libc6_2.28-0ubuntu1_amd64.deb && sudo dpkg -i libc6_2.28-0ubuntu1_amd64.deb
 

EduardoKST

Well-known member
Code:
root@TS3HH:~# sudo dpkg -i libc6_2.28-0ubuntu1_amd64.deb
dpkg: regarding libc6_2.28-0ubuntu1_amd64.deb containing libc6:amd64:
 libc6:amd64 breaks locales (<< 2.28)
  locales (version 2.23-0ubuntu10) is present and installed.

dpkg: error processing archive libc6_2.28-0ubuntu1_amd64.deb (--install):
 installing libc6:amd64 would break locales, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
 libc6_2.28-0ubuntu1_amd64.deb
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Hmm im not sure why you get this now and not earlier. I think this is may related to protobuf (which I use). I hade some trouble with it in build 3.
 

xDyego

Well-known member
Premium User
I have this same error, I am using the latest version. TeaSpeak-1.2.27-beta-3.tar.gz
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Well it seems like im ahead of the official version.
Types ldd --version to identify your version :)