• Be part of the TeaParty!
    Click here for more information

Information How to get TSviewer/TS3index/gametracker to work.

mkll11one

TeaFanatic
Premium User
Hello and welcome to this guide.
Here I will guide you with: How can I getting the: TSViewer/TS3index and gametracker to works on my server!


First, you need to do: - Go to your putty or SFTP. - Open the config.yml, and check the "MOTD" about it's correctly like (this):
Code:
motd: "TS3\n\rWelcome on the TeaSpeak ServerQuery interface.\n\r"
If you don't have (this) on the MOTD. - use this! ;)

YatQTA information
After that, you need to open YatQA > login to your server (as server admin) after you are logged on. Go to "Servers" > Choose the on server (it does not matter which!) > Go to permissions - (Here it is extremely important):

It may well be that you need to change the two groups. (Guest OR Guest Server Query)
Permissions:

Code:
b_virtualserver_info_view
b_virtualserver_channel_list
b_virtualserver_client_list
b_virtualserver_servergroup_list
b_virtualserver_channelgroup_list
b_virtualserver_connectioninfo_view
b_virtualserver_channel_list
b_client_remoteaddress_view (Optional)
And you need to do this (only) >
(you don't need to type on Grant!)

After that. it should works on TS3index, TSviewer and gametracker!
**Note**: sometimes gametracker (maybe) accept the "DNS" and only works with IP!
** Second Note**: There is a risk that your server will already be greylisted or blacklisted by TeamSpeak! (I have been greylisted 2x. and it's no longer possible to be unbanned!)

*** Third Note (Related to GameTracker) ***
Game tracker specially required this MOTD:
Code:
motd: "TS3\r\nWelcome to the Tea*Speak 3 ServerQuery interface, type \"help\" for a list of commands and \"help <command>\" for information on a specific command.\r\n"
Update from 24-06-2019:
GT Should work now (1.3.21-beta1).
 
Last edited:

mkll11one

TeaFanatic
Premium User
//Second note added about the risk for be "greylisted or blacklisted by teamspeak" ;)
 
Last edited:

ZEBI

Member
And you did updated the config.yml and restarted the server? ;)
#The query welcome message
#Notice: If not like Tea*Speak then some applications may not recognize the Query
#Default Tea*Speak 3 MOTD:
motd: "TS3\n\rWelcome on the TeaSpeak ServerQuery interface.\n\r"
 

mkll11one

TeaFanatic
Premium User
Well, i can't reproduce the issue. i don't have any issues! :)

And you are sure, you have try to set (these permissions to be "Yes"?)

Code:
b_virtualserver_info_view
b_virtualserver_channel_list
b_virtualserver_client_list
b_virtualserver_servergroup_list
b_virtualserver_channelgroup_list
b_virtualserver_connectioninfo_view
b_virtualserver_channel_list
b_client_remoteaddress_view  << I think this need to be applied!
For i got no problem, it works here. i have tested on 5 random TeaSpeak servers.
 

ZEBI

Member
Well, i can't reproduce the issue. i don't have any issues! :)

And you are sure, you have try to set (these permissions to be "Yes"?)

Code:
b_virtualserver_info_view
b_virtualserver_channel_list
b_virtualserver_client_list
b_virtualserver_servergroup_list
b_virtualserver_channelgroup_list
b_virtualserver_connectioninfo_view
b_virtualserver_channel_list
b_client_remoteaddress_view  << I think this need to be applied!
For i got no problem, it works here. i have tested on 5 random TeaSpeak servers.
b_client_remoteaddress_view

this is risk
 

norbee.16

New member
The problem persists. Permissions are still not saved on the server. The latest teaspeak version is on the server.

I've tested on a new server, even though this is the problem. (It runs from my server.)

 

mkll11one

TeaFanatic
Premium User
The problem persists. Permissions are still not saved on the server. The latest teaspeak version is on the server.

I've tested on a new server, even though this is the problem. (It runs from my server.)

No problem here. ;) try assign the permissions via "own client" or do it from YaTQA ;)