Completed The virtual server is not enabled.

Vafin

TeaFanatic
Hey. After a while, the teaspeak server, if you turn off the virtual server, then back it is not included until you restart the entire instance. What could be the problem?Processor and memory readings are normal.

1537117879303.png
 

Kevinos

Fanatic member
Premium User
Yes I have the same problem when I delete a server, and re create it with the same port, I am forced to completely restart teaspeak
 

Vafin

TeaFanatic
The most interesting thing is that after restarting teaspeak server problem disappears, but after a while again occurs.
 

Vafin

TeaFanatic
I found the cause. The TeaSpeak and ffmpeg ports are the same. As soon as I kill ffmpeg the server starts working immediately. Please fix this bug as soon as possible.
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
Im still a little bit confused, why FFMPEG uses UDP ports?!
Specially the ports which TeaSpeak use as well.
My first thought that this is just a displaying error and the process isnt ffmpeg instead its TeaSpeak
 

Vafin

TeaFanatic
Im still a little bit confused, why FFMPEG uses UDP ports?!
Specially the ports which TeaSpeak use as well.
My first thought that this is just a displaying error and the process isnt ffmpeg instead its TeaSpeak
Is there any way to fix the port conflict? Or while to abandon the music bot?
 

mkll11one

TeaFanatic
Premium User
Im still a little bit confused, why FFMPEG uses UDP ports?!
Specially the ports which TeaSpeak use as well.
My first thought that this is just a displaying error and the process isnt ffmpeg instead its TeaSpeak
I think it's because it using the "port" to connect to the server (maybe?)
 

WolverinDEV

TeaSpeak Team
Staff member
Administrator
After upgrading to 1.2.18-beta, the bug still persists.
Never fixed it there, I'm still searching for a way to reproduce it and to determine how ffmpeg listen on ports, because for me locally it doesn't do that :D
 

Vafin

TeaFanatic
Never fixed it there, I'm still searching for a way to reproduce it and to determine how ffmpeg listen on ports, because for me locally it doesn't do that :D
To play this you need to:
1) Install teaspeak on VDS
2) Create more than 2 virtual servers using yatqa
3) Run the music bot on any virtual server
4) turn Off any virtual server where there is no music bot and try to start it again.
 
Last edited: